Jobs are running slowly

Incident Report for Midjourney

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 09:14 UTC

Update

Fast and Turbo jobs have recovered, but Relax jobs are still backlogged.
Posted Feb 12, 2026 - 08:56 UTC

Investigating

We are currently investigating this issue.
Posted Feb 12, 2026 - 08:41 UTC
This incident affected: API (Image Generation - Fast & Turbo, Image Generation - Relax) and Web, Bot.