Jobs are queueing

Incident Report for Midjourney

Resolved

We've implemented a fix and wait times have recovered.
Posted May 19, 2026 - 10:43 UTC

Update

We've implemented a fix and wait times for fast mode jobs are recovering.
Posted May 19, 2026 - 10:39 UTC

Update

We've implemented a fix and wait times for fast mode jobs are recovering.
Posted May 19, 2026 - 10:27 UTC

Update

We've implemented a fix and wait times are recovering.
Posted May 19, 2026 - 10:25 UTC

Monitoring

We've implemented a fix and wait times are recovering.
Posted May 19, 2026 - 10:23 UTC

Investigating

We're investigating longer-than-usual wait times for jobs.
Posted May 19, 2026 - 10:08 UTC
This incident affected: API (Image Generation - Fast & Turbo, Image Generation - Relax) and Web, Bot.