Some job types are seeing long delays

Incident Report for Midjourney

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 00:27 UTC

Update

We are continuing to investigate this issue.
Posted Feb 26, 2026 - 00:18 UTC

Investigating

Some job types are seeing long delays. Both fast and relax modes are affected.
Posted Feb 26, 2026 - 00:17 UTC
This incident affected: API (Image Generation - Fast & Turbo, Image Generation - Relax) and Web, Bot.